Disclaimer: There are many, many ways to approach web design. This tutorial is neither the most “cutting-edge” nor most efficient. Instead, this tutorial is set-up to show you as many functions in Photoshop and Dreamweaver without being unnecessarily overwhelming. Please email me with comments or concerns (brian.ballentine@mail.wvu.edu).

Photoshop tutorial:

A good way to begin a new web design project is by sketching thumbnails of your page design. Recall chapter 13 from Anderson on document design – specifically page 378. In this example I model the “personal” page seen below on the structure of a very basic approach to web site. It is a “classic” design that works well for a beginning an information page.

Final Product in Photoshop:

The page is 800 pixels wide by 600 pixels high. The light blue lines that you see in the picture are not part of the final design but guides that help us with the layout. Let’s launch Photoshop and get started…
Tool bar:

The design above only requires basic knowledge of the tools below. We can cover others if there is time/interest but these will get you through.
**Getting Started:**

Click on the “File” menu in the upper-left corner.

Select “New” from the options.

This menu appears:

![New Menu](image)

Since we are designing for 800 x 600 pixels make sure that the Width and Height are correct and that they are measured in Pixels not Inches or other measurements. Leave all of the other settings alone. That is, the resolution is 72 pixels per inch, RGB color with a White background.
Rulers:

When your new page loads the Rulers around the boarder of the page may or may not be showing as in the partial screenshot below:

If they are NOT showing, click on the “View” menu and select “Rulers.”
After you have turned the Rulers on or if the rulers are already showing make sure that the rulers are measuring in Pixels. To activate the “Preferences” for the Rulers double-click anywhere on one of the rulers and you will see:

![Preferences dialog box]

Be certain that the “Units” for “Rulers” reads “pixels” and you will be all set.
Guides:

The light blue lines mention on page 1 are guides that we can manually put in place to make certain that we are precise with our layout.

Place your cursor over the top or horizontal ruler and click-hold-and-drag downward. A dotted back line should appear that you can place anywhere on your new page. Line-up the guide with the 100 pixel mark on the vertical ruler and release.

Repeat the process with the vertical ruler but this time line-up the guide with the 150 pixel mark from the horizontal ruler. The final product should look like:
Layer Palette:
The layer palette on the left (below) is what you see after you create a “new” page in Photoshop. There is only one layer and it is labeled as “Background”. The layer palette on the right is a screen shot from the final product seen on page 1. Each layer contains a different graphical element from the design. Think of the layers as individual sheets of transparent paper stacked on top of one another. Photoshop lets you control each design element separately so we can make modifications to the design as we go. Type or text layers are automatically created for us when we use the Type Tool. Other design elements such as the “square,” and the horizontal and vertical lines need to be created manually. Let’s choose a color for our text and then use the Type Tool.
**Color Palette/Swatches**
Click on your Foreground color swatch in the Tool Bar and you will see the Color Picker as below:

Manually move the arrows up and down the color bar (middle) to find the color you want. Click OK.
Type tool:
Select the Type Tool from the tool bar and click in the upper area of the document where you want to type your name. Notice at the top of the screen there are the standard configurations for adjusting the type face and font, point size, justification, etc. Make adjustments as you see fit. In the example, I am using Times New Roman at 72 points. The cursor should be flashing and you can go ahead and type. If you do not like the style of the type you may use the type tool to highlight the text and make adjustments. At any point in the design process you can come back to this text by double-clicking on the “T” in the layer palette and the layer will activate.
Add Layer:
Before using the marquee tool, (next step) manually create a new layer for the square you are about to fill-in. From menu options at the top of the screen use, “Layer” – “New”- “Layer” to accomplish this. Name the layer “square” or something else you will remember.
**Marquee tool:**
Set the cross hairs outside of the screen in the upper left corner. Click-hold-and drag over the area you wish to select. You should “feel” the marquee tool “snap to” the guides when you get close enough to them. If this does not occur, go to “View” – “Snap To” – “Guides” to activate.
Paint Bucket Tool:
Select the Paint Bucket Tool from the Tool bar. It may be that the Gradient Tool is showing in its place. Simply click and hold on the Gradient Tool to toggle between the two tools. Gradient tool is shown below:

Once the paint bucket tool is selected, place your cursor (which now looks like a bucket) into the marquee area and click. The area will change color to the color that is your foreground color selection.
Add Monogram Letter
Once again select the Type Tool and place the cursor over the red square. Click to activate the cursor and type your initial. If your type is still set to the same color as the color of the square (in this case red) you will need to highlight the initial and change the color and possibly the font and size. To change the font color, simply click on the color swatch at the top of the screen:
Add Menus and Guides for Menus

Once again activate the Type Tool. Place the cursor underneath the monogram initial and click. Type in the menu items you wish to have in your web site and after each hit the “Return” key. Use the type tool configurations to make proper adjustments to font style and color:

Once you have the buttons in place, drag guides between all of the buttons. You do not have to worry about the exact height of the guides.
Adding Horizontal and Vertical Lines
Click and hold on the Marquee tool in the Tool bar and select “Single Row Marquee Tool.” Before using the tool, manually add a new layer by selecting “Layer” – “New” – “Layer” and name the layer “Horizontal Line.” Place the marquee tool anywhere on the horizontal guide that lines up with your 100 pixel mark and click. You should see the “marching ants” or dashed line running along the guide.
Stroke or Paint the Marquee Line

Under the “Edit” menu at the top of the screen select “Stroke” and you will see this window:

The width represents how thick the line will be and the color shows the color of the line after it is painted. You can leave the Location set to “Outside.”
After hitting “OK” the line should appear as below:
Repeat the same process to add the vertical line. First, add a new layer and title the layer “Vertical Line.” Next, select the “Single Column Marquee Tool” and place the cross-hairs on the vertical guide at the 150 pixel mark and click. After the “marching ants” appear, select “Stroke” from the “Edit” menu as above. Result:
Adjustments to the Vertical and Horizontal Lines

The vertical and horizontal lines are drawn right over the top of the guides and we need to make sure that the vertical line is to the left of the guide and that the horizontal line is on top of or just above the horizontal guide.

So, the easiest way to de-select the single column marquee tool which is still showing on your image is to select the rectangular marquee tool again and click anywhere outside of the image. This will clear the “marching ants.”

Now select the “Move Tool.” Next, select either the vertical or horizontal line in the layer palette. Using the arrow keys on your keyboard you can now make pixel-by-pixel adjustments to the placement of the lines. So, with the horizontal line selected, use the “up arrow” key to move the line above the guide. Select the vertical line and use the “left arrow” key to move the vertical guide sideways. It may help to Zoom-in (use magnifying glass from the tool bar or “Shift” plus the “+” or “−” keys) on the lines to be certain as below:
**Eraser Tool**

Use the eraser tool to create the faded or feathered effects at the end of both the vertical and horizontal lines.

There are 3 options to choose from for the eraser tool but you will only need the first setting which is “Eraser Tool.” After selecting the tool, new menus appear at the top of the application that are seen in the screen-shot below:

First, make sure that your “Mode” is set to “Brush” and not “Pencil” or “Block.” By “Brush” Photoshop means “airbrush-like” and your next step is to select the nozzle-type for the brush. So, next to “Brush” pull down the menu until you find this setting:

Select the “200” setting with the “soft edge” shown above. There will be many choices but scroll until you locate this one.
Using the Erase Tool

The erase tool will now appear as a large circle on the page. With the vertical guide selected, click and hold the mouse to begin erasing the line from the bottom up. The eraser will only work on the layer that is selected. Remember that Photoshop has an “undo” feature under the “Edit” menu if you are not happy with how things are going.

Repeat the process for the horizontal line.
Save!

It is always a good idea to save your work as you go. Select the “File” menu and then “Save.” Decide on the folder or directory where you want to build your website. You may want to create a new directory for this. As with most file types for the web, your life will be much easier if you do NOT use spaces when naming any folder or file. Alternate suggestions include: myFolder, my-folder, my.folder. In Photoshop - you will be asked to name the file so pick something intuitive. Notice that the file format says “.psd” which is Photoshop Document for short. Leave this setting. The .psd format preserves the layers. Other formats, jpg, tif, gif, will flatten and compress the image and you will not be able to make edits to the layers.
Cropping and Saving

Now we must take the image apart and save individual pieces as compressed GIFs. We will then put those images back together in Dreamweaver (next tutorial).

Using the Rectangular Marquee Tool, select the red square and your name by starting outside the image in the upper-left corner. You will be capturing the top portion of the graphic that is 800 pixels wide and 100 pixels high. Use the guides and the “snap to” function to make certain you have that area selected as below:

Select the “Image” menu and then find the “Crop” selection. Your graphic will now be reduced to the 800 by 100 area you selected. (Don’t worry, we can get the rest of the graphic to return.)

Now you are ready to Save. Under the “File” menu select “Save for Web.” A new screen appears with your image showing. There are tabs at the top of the screen and one is labeled “4-up.” Select this tab to show different compressed versions of your image and file sizes. Do not pick the “original image” which is the .psd but choose one of the other three based on image quality. The file sizes should not vary too much. In this example the largest is 18k and the smallest 15k. See below:
Cropping and Saving

Select one of your images and hit “Save.” You will be prompted to name this file. Again, select an easy to remember file name like “titlebar” or “header”. Photoshop automatically has the file extension set to “.gif” so do not adjust that setting. Once you are finished you will see your cropped image again.
The History and Actions Palette

While Photoshop does have an “undo” feature available under the “Edit” menu, it also has a more advanced “History” palette that keeps track of your actions and edits. The History and Actions palette usually opens by default along with the layers palette in the right-hand corner of the application. If it is not showing, select the “Window” menu and check “History” for it to appear. It will look like:

Select the “Rectangular Marquee” action and the image will change back to its state prior to cropping. Use the “Trash Can” icon in the lower right corner of the History palette to delete that action and all that come after it. So, the image will appear as if you’ve never cropped it or even selected the top portion.
Cropping the Buttons

Next we have to select and crop out each of our buttons. (Please note again that this is only one way to make links or buttons for web pages. We are making “roll-over buttons that require a little bit more work. There is nothing wrong with using plain HTML text to make links in Dreamweaver.) So, using the marquee tool, line up with the 100 pixel guide to the left of the graphic just on the outside of the button and select and crop as below:

Once again we are going to use the File and Save for Web function. Select one of the four images and hit save. Since we are making roll-over images we need to save two versions of each button. This is where good naming conventions are very important. I would call this button something like “resume.red.gif” to make sure I can tell the two apart. Rather than jumping to use the undo or history palette, create your other version of the resume button now. Since you can still make changes via the layer palette, double-click the “T” (text) for the buttons and you will be able to change the color of the word resume to black or another roll over color. Once you do this, repeat the Save for Web process and name this button “resume.black.gif” Now you can use the History palette to revert.
Crop out all of the buttons and the bottom of the Vertical Line

Repeat this process for each of your buttons. When you are finished you will need to capture that tail end of the vertical line. Make sure you have a guide just below the point where your line finishes with its fade. In this example there is a guide at the 400 pixel mark:

Crop out this portion of the image by once again selecting the “image” menu and then the “crop” selection. Use the Save for Web function and name the image something intuitive.

Now that we have all of these pieces, it is time to reassemble them in Dreamweaver.