[image: image1.png]


[image: image81.png]SEIES

e Edi Took Show/Goto Valdale Project Dbiect Window Help 18] x|

3| al|B(B[sB] Alzsm|E] 88| M [o|3[=[of ~ His| B alalall

. _ Drver_Command® T
e - '

DislaysT |

oy Tt Postion’

Drve_Shate

Shatt_Retation” kg™~ — | Brke”

Calbrats Paramates”

ransmission” ' Dxaase”

|



 PAGE  \* MERGEFORMAT 
ii

AxiomSys Tutorial

[image: image82.png]Data ltem Name:
]

Dataltem List:
Activate
Average_Spesd
Bodlean
Calbrate_Cammand
Deactivate
Defaul_Count
Fuel_Cansumplian
Lower_Linit
Maintenance_Needed
Moritor_Command
Resume
Start_pccslerate
Stop_pccslerate
Top_Gear_Off
Top_Gear_On

Display

& Undsfined Data lems.
 Defined Data tems
© Uneferenced Data tems




Contents
i

2

1 Structured Analysis Overview

2 Creating the Project
3


3 Creating the Context Diagram
3


3.1 Adding  a Process
3


3.2 Moving/Re-sizing a Process
4


3.3 Adding a Terminator
4


3.4 Adding Data and Control Flows
4


3.5 Moving  a Data Flow
5


3.6 Saving the Context Diagram
6


3.7 Adding Control Flow
6


3.8 Adding P-specs to a Project
6


3.9 P-spec Balancing
8


3.10 Adding Terminator Text
8


3.11 Entering Data Item Definitions
9


3.12 Browsing Data Items
12


4 Child Flow Diagram Creation
13


4.1 Adding a Process
14


4.2 Adding a Flow
14


4.3 Adding a Data Store
16


4.4 Balancing Flow Diagrams to Processes
18


4.5 Adding a Bar
18


4.6 Browsing P-specs
20


4.7 Browsing Flow Diagrams
21


4.8 Adding a C-spec
22


5 Validating the AxiomSys Project
27


6 Creating Reports
27


6.1 Creating a Report Template
27


6.2 Printing the Report
34


7 Architecture Modeling Overview
35


8 Creating the Architecture Context Diagram
35


8.1 Adding a Module
36


8.2 Adding a Terminator
37


8.3 Adding an Architecture Data Flow
37


8.4 Adding Channels
38


8.5 Adding a Module Specification
40


8.6 Adding a Terminator Specification
40


8.7 Adding a Data Item Definition
40


8.8 Adding a Channel Specification
40


8.9 Assigning a Data Item to a Channel
41


9 Creating Architecture Flow Diagrams
42


9.1 Adding Architecture Data and Control Flows
43


10 Creating Architecture Interconnect Diagrams
45


10.1 Adding a Channel
45


11 Validating the Model
47


12 Generating the Essential Model Diagram for the Context Module
48


13 Generating the Enhanced Flow Diagram for the Context Module
49


14 Generating the Essential Model diagrams for the Child Modules
51


15 Generating the Enhanced Flow Diagrams for the Child Modules
58





Introduction to AxiomSys

AxiomSys is a CASE tool which combines the methods of Structured Analysis with Real-Time Extensions and Architecture Modeling to provide a complete solution to the problems of systems requirements modeling. 

This tutorial is separated into three parts. Parts 2 and 3 describe the Architecture modeling features and can be skipped if you are concerned only with Structured Analysis.

· Part 1 will guide you through the Structured Analysis capabilities of AxiomSys.

· Part 2 will guide you through the Architecture Modeling capabilities of AxiomSys. 

· Part 3 will integrate the Structured Analysis and Architecture Models. 

This tutorial will lead you through an introduction to many features of the tool, including many unique productivity enhancing features.  The tutorial is based on the Cruise project, delivered as part of the demonstration and commercial versions of the tool.

After you have studied this tutorial, you can then open the Cruise project and further investigate the complete capabilities of the AxiomSys CASE tool.

This tutorial is intended as an introduction to AxiomSys and not to the methods of Real‑Time Structured Analysis and Architecture Modeling.  If you are unfamiliar with these methods, the following books provide an excellent introduction to the methods.

· Tom DeMarco, Structured Analysis and Systems Specification. Englewood Cliffs, N.J.: Prentice-Hall, 1979.

· Derek J. Hatley and Imtiaz A. Pirbhai, Strategies for Real-Time System Specification. New York, N.Y.: Dorset House Publishing, 1987.

Additionally, STG, Inc. provides courses in the methods of Structured Analysis, Real-Time Structured Analysis, and the use of AxiomSys.  Contact STG, Inc. for additional information.

System Requirements:

· MS Windows 95, 98, or NT 

· Memory: 16 MB minimum.

· Disk space: 3 MB minimum.

· Printer: any device compatible with MS Windows.

· Mouse: any mouse compatible with MS Windows.

To Install:

· Start MS Windows

· Insert the first AxiomSys disk to the drive.

· Execute the file setup.exe on the AxiomSys disk.

Part I. Building a Structured Analysis Model

1 Structured Analysis Overview

Structured Analysis is a method to describe the essential requirements of the system that you want to build. One of the most important concepts of the method is that the Structured Analysis model should be independent of the technology that will be used to implement the system. The technology decisions will be added in the Architecture model (see Parts 2 and 3 of this tutorial).

In Structured Analysis, your system can be thought of as a process that transforms the inputs of your system into the outputs from your system. This process is then decomposed or refined into a set of simpler child processes.  The child processes are then further refined as necessary until processes that require no further refinement are reached. The processes that require no further refinement are called primitive processes. A primitive process is one that completely describes it's transformation of inputs to outputs in an unambiguous and testable way. 

Process input and output data are defined as data dictionary items, or, data items for short.  Each data item must be defined and must be decomposed to its primitive elements.  The data item definition can be composed of a textual description, a structural description or both.  A simplified BNF (Backus-Naur) format is used to describe the data item structure.  For details on the BNF, refer to Paragraph 3.11, Entering Data Item Definitions.  The data item structure is used to decompose the data item.  Primitive data items only have a textual description.  If a data item definition is not entered, the data item is undefined.

Flow diagrams, p-specs and c-specs are used to describe a process.

A flow diagram is a graphical means to describe a process.  It shows the data flows, the control flows, the data stores, and the child processes of the process.  A data flow is a solid directed line, with data items attached to it, showing where the data items originate and where they terminate.  A control flow is a dashed directed line, with data items attached, showing the direction of control flow.  A flow diagram is where you declare the child processes of a process.  When a data item is first entered on a data flow, a control flow, a data store or a data item structure, it is not defined; it is only declared.  A data item definition must be entered for it to be considered as a defined data item.

The top level flow diagram gives an overview of the system you are modeling and it is called the context diagram.  Terminators are used in a context diagram to show the external interfaces to and from the system you are modeling.  You can enter text to describe terminators.  If the terminator description is entered, the terminator is a defined terminator.

A p-spec (process specification) is a textual means to describe a process.  If a p-spec is entered for a process, the p-spec is a defined p-spec.
A c-spec (control specification) is a graphical means to describe control information for a process.  A c-spec can be a state transition diagram, a control table, or a c-spec guide. The c-spec shows the various states of the process, the events that cause a state change, the data items that are generated, and the processes that get activated.

Trace files and trace items are not part of the Structured Analysis model.  However, they are incorporated into AxiomSys as a productivity aid.

Trace files can be thought of as folders containing trace items.  A trace item is text that can be linked to p-specs, c-specs, and data items.  Trace files and trace items are most widely used for requirement tracing.  Normally, the system you are modeling has some high-level requirements that must be satisfied.  By entering the high-level requirements as  trace items and linking these trace items to p-specs, c-specs, and data items, you can quickly find out which parts of the model satisfy the high-level requirements.

2 Creating the Project

All the information for a model is contained in a project data base.  The project can exist in any drive or directory that can be accessed from your computer.

The project that will be created for this tutorial is titled “new.”

To create the project,

· Select the Project menu, and the Open option.

· In the resulting dialog box, enter “new” in the File Name field and select Open.  Do not add a file extension to the name because AxiomSys will automatically append the correct file extension required by the tool.

· Select the Yes button when asked to confirm the project creation.

3 Creating the Context Diagram

The project to be built is the Cruise model.  To start the model, you will first create the context diagram for the project.

To create the context diagram, 

· Select the Context Diagram icon, [image: image83.png]AxiomSy:
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· When the Context Diagram dialog box is displayed, enter “Cruise_Control” and click on the Edit button.  

An empty flow diagram window will be displayed.

3.1 Adding  a Process

Add the process Control_And_Monitor_Auto to the diagram as follows:

· Select the Create Process icon, [image: image2.png]


.

· Position the cursor in the center of the diagram, and click the left mouse button.

· In the Create Process dialog box, enter “Control_And_\Monitor_\Auto” in the Name field, “0” in the Number field and clear the Is Primitive check box. The Process Attributes dialog is shown below.

[image: image3.png]Number [0 ™ Is Bimitive




· Select the OK button.

In the Create Process dialog box, note that:

· The backslash is used to indicate where a carriage return/line feed is desired on the diagram.

· In a context diagram, the process number is defaulted to 0.  In other flow diagrams, the process number for the first process is 1 and incremented for every process thereafter.  The process number is used to specify the order of the processes during report generation.

· The Is Primitive check box is cleared to indicate that the process is not a primitive process.  A primitive process does not have any child processes.

The newly created process on the context diagram is shown below.
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Note:

· The process is grayed.  Graying of the process is used to indicate that the process is not a primitive process, and that no child flow diagram exists for the process.

· An asterisk is displayed next to the process name.  This indicates that the p-spec for the process has not been defined.

· If a process is a primitive process, the process name will be displayed in bold text.

This information is part of the Intelligent Diagram information presented on AxiomSys diagrams.  You can tell at a glance the work remaining to be done by looking at the displayed diagram.

To exit the create process mode, click on the Go to select mode icon, [image: image5.png]


, located on the tool bar.

3.2 Moving/Re-sizing a Process

To move a process, click on the process and drag it to the new position.

To resize a process, click on the process to select it.  When the re-sizing points are displayed, click on one of them and drag to resize.

3.3 Adding a Terminator

Next, enter the terminators on the diagram.  Refer to the diagram on page diagram below for the location and name of the terminators.  In the diagram, note the asterisk following the terminator name.  The asterisk indicates that the terminator is undefined (the terminator description has not been entered).

To create a terminator:

· Click on the Create Terminator icon, [image: image6.png]


, located on the tool bar.

· Position the cursor where the terminator is to be located, and click the left mouse button.

· When the Create Terminator dialog box is shown, enter the terminator name in the Terminator field. If the terminator name is too long, you can insert a backslash, “\”, in the terminator name to break up the terminator name into multiple lines.

· Click on the OK button and the terminator will be displayed on the diagram.

To exit the create terminator mode, click on the Go to select mode icon, [image: image7.png]


, located on the tool bar.

Moving or re-sizing a terminator is similar to moving or re-sizing a process.  For details, refer to Paragraph 3.2, Moving/Re-sizing a Process.

3.4 Adding Data and Control Flows

Next, generate a data flow connecting terminator Drive_Shaft to process Control_And_Monitor_Auto in the following manner:

· Click on the Create Data Flow icon, [image: image8.png]


, located on the tool bar.

· Position the cursor inside the terminator Drive_Shaft, and click the left mouse button.

· Move the cursor inside the process Control_And_Monitor_Auto and double click the left mouse button.  You can insert intermediate points on the data flow by single clicking the left mouse button before the final double click within the process.

· In the Create Flow dialog box, enter “Shaft_Rotation” in the Data Item field.

· To add this name to the List of Data Items on Flow, select the Add/Remove button.  You will notice that the name in the List of Data Items on Flow is followed by an asterisk.  The asterisk indicates that the data item definition has not been entered in the data dictionary.

· Select the OK button to complete the creation of the data flow.

Add the remaining data flows to the flow diagram to make it appear as following:




To exit the create data flow mode, click on the Go to select mode icon, [image: image9.png]


.

Notice the asterisks following the data item names on the data flow.  The asterisks indicate that the data items do not have definitions in the data dictionary.

3.5 Moving  a Data Flow

To move data item names attached to data flow, click on the data item names and drag them to a new location.

To add points to a data flow, click on a segment of the data flow and drag.

To remove a point from a data flow, click on the data flow and then click and drag the point to an adjacent point on the data flow.

To move a point on a data flow, click on a segment of the data flow and then click and drag the point to its new location.

3.6 Saving the Context Diagram

Up to now, none of the work has been saved to the project data base.  You have only been drawing the diagram on the screen. To save this incomplete diagram to the data base, select the File menu and Save or select the save icon, [image: image10.png]


 .  

At this point, the flow diagram is saved to the data base.

3.7 Adding Control Flow

Now, add the control flows to the diagram. This is done in exactly the same manner as adding data flows, but the icon to be selected from the tool bar is the Create Control Flow icon, [image: image11.png]


.  The resulting flow diagram should look as follows:


This diagram is now complete.  To save it, select the File menu and click on Save or select the Save icon, [image: image12.png]


.

3.8 Adding P-specs to a Project

You will now add the p-specs to the project.  It is recommended that p-specs be written for the context diagram and all processes in the system.  Writing these p-specs will allow for the generation of a final report that will be much easier to read and understand than if p-specs were written only for primitive processes. 

To enter the p-spec for the Context Diagram, select the Go to icon, [image: image13.png]


, located on the tool bar and click on Go to Associated P-spec or right click in empty space on the diagram and select Go to Associated P-spec from the pop-up menu..

An empty p-spec window will be displayed.  Enter the following information:

The Cruise model represents a cruise control system for an automobile.  The system includes not only the normal cruise control features, but also the ability to calibrate the system, and also includes features for maintenance monitoring.

To save the p-spec, select the File menu and click on Save or select the Save icon, [image: image14.png]


.

To return to the Context Diagram, select the Show/Go to  pull-down menu and click on Go to FD.  This will display the flow diagram with the same name as the p-spec.

You will now enter the p-spec associated with the Control_And_Monitor_Auto process:

· Right click on the Control_And_Monitor_Auto process and select Edit P-spec from the pop-up, or.

· Double right click on the Control_And_Monitor_Auto process while holding the control key down.

The associated p-spec window will now be displayed.

Select the Show/Go to menu and click on Inputs/Outputs.  The P-spec Input/Output dialog box will be displayed. This dialog box will be used to aid in entering references to flows in the p-spec.
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P-specs associated with processes are descriptions of the transformation of the input data items to the process into the output data items from the process.  In describing this transformation, you will want to reference the names of the input and output data items of the associated process.  The P-spec Inputs/Outputs dialog box aids in entering these references.  There are two selectable lists in the dialog box, one shows the list of inputs to the associated process, and the other shows the list of outputs from the associated process.  To add one of these inputs or outputs to the text of the p-spec, position the cursor in the text where the reference is to appear, and double click the name in the list.  The reference will be automatically entered into the text.  The reference appears as IN(name) for an input reference and OUT(name) for an output reference.

The purpose behind identifying these references is two-fold.  First, balancing between the p-spec and the process on the flow diagram can be performed.  This will ensure that all inputs and outputs to the process are used in the p-spec, and that the p-spec does not reference data items that are not available to the process.  Second, the references allow for the global renaming of data flows with the new names appearing in the p‑specs, thus maintaining the consistency of the model.  You will now experiment with these features.

Enter the following into the p-spec window for Control_And_Monitor_Auto:

This process is controlled by the driver via IN(Driver_Command).  The driver turns the cruise control on and off and selects the speed.  The system is also affected by whether the car is in IN(Top_Gear) and whether the car is currently IN(Braking).  The cruise control is only available when the car is IN(Running).  The IN(Shaft_Rotation) is used in speed and distance determination.

In determining speed from the IN(Shaft_Rotation), it is necessary to know the number of rotations per mile.  The IN(Calibrate_Parameters) is used to determine this value.

The car speed is ultimately controlled by the command OUT(Throttle_Position).

After the text has been entered, select the File menu, and click on Save to save the p‑spec or select the Save icon, [image: image16.png]


.

3.9 P-spec Balancing

Next, select the Validate menu and click on Balance P-spec against Process to balance the p‑spec to its associated process. 

Balancing errors will be displayed in a new window.

Examine the errors and you will find that the following data items are not referenced in the p‑spec:

· Data item Fuel_Quantity, which is an input to process Control_And_Monitor_Auto, is not used in the p‑spec.

· Data item Displays, which is an output from process Control_And_Monitor_Auto, is not used in the p‑spec.

To correct these errors, append the following paragraph to the p‑spec: 

The driver can also request various status OUT(Displays).  These displays include speed, trip distance, average speed, fuel rate, etc.  In order to calculate fuel‑consumption, the driver must enter IN(Fuel_Quantity).

After adding this paragraph to the p‑spec, save the p‑spec again, and perform the validation once more.  If you have entered everything correctly, the message “No error found” will be displayed.

Select the Show/Go to menu and click on Go to  Parent Flow Diagram to return to the parent flow diagram.  The parent flow diagram is the flow diagram containing the process associated with the p-spec.  You should observe that the asterisk following the process name in the bubble is gone.  This indicates that the process now has an associated p‑spec.

3.10 Adding Terminator Text

The next step in building the model is to add the text that defines the terminators shown on the context diagram.  First, you will add the text associated with the terminator Database:

· Right click on the terminator Database, and select Edit Terminator Specification from the resulting pop-up menu or double right click on the terminator DataBase while holding the control key down.

· In the Terminator Database window, enter the following text:

This is the data base information that must be supplied in order to generate the Control and Monitor Auto system.  There is no actual interface to this data base.  It is only present to provide a definition of the information that is necessary to implement the system.

· Select the File menu and click on Save or select the Save icon, [image: image17.png]


, to save the terminator Database definition in the project data base.

· Select the File menu and click on Close to close the Terminator Database window.  In the context diagram Cruise_Control, notice that the asterisk after the terminator Database is no longer displayed.  This indicates that the terminator definition has been entered.

Now, add the text associated with the remaining terminators on the context diagram Cruise_Control.  The text for each terminator is given below.

Driver

This is the driver who interfaces to the system to enter requests for operations.  The requests are interfaced to the system by interrupts.

Drive_Shaft
This is the drive shaft which interfaces to the system to provide the shaft pulses.  The pulses are provided to the system by an interrupt.

Transmission:

This is the transmission. The transmission provides the current gear information to the system.  The interface is implemented by an interrupt which is  generated whenever the gear changes.

Engine:

This is the engine that interfaces to the system to provide the current running status.  The status is provided to the system by an interrupt.

Brake:

This is the brake that interfaces to the system to provide braking status.  The interface from the brake is by an interrupt when the braking status changes.

Throttle:
This is the throttle.  It receives throttle commands from the system by a serial interface.

3.11 Entering Data Item Definitions

To complete the context diagram entry, it is necessary to define the data items for the data and control flows that are present in the diagram.  

Data item definitions are composed of textual descriptions and/or structural descriptions.

The text descriptions appear in the upper sub-window of the data item window.

The structural descriptions, if any, are entered in the lower sub-window of the data item window.

The structure is defined using a simplified BNF (Backus-Naur format) as follows:

+
means AND.  A data item, A, whose structure consists of several independent components has its structure represented as A1 + A2 + A3. The symbol ‘+’ separates the members of the structure.

( ) 
means that the component is optional.  If a member of the structure is optional, i.e. it may or may not appear, the name of the optional component is placed inside parenthesis as (A1).

[A1|A2|A3]
means EITHER A1 OR A2 OR A3 may be present in the data or control flow.  This type of data structure consists of independent components, and represents a mutually exclusive selection.

{ }
means ITERATIONS OF the enclosed component.  The iteration operator says that everything enclosed within the braces is repeated.  Unadorned braces mean "from zero to infinity repetitions of the component enclosed."  Example: A = {A1} means that A consist of zero to infinity iterations of A1.


To apply a lower limit to the number of iterations, precede the first brace with an integer defining the minimum number of iterations.  For example: 1{A} means one or more iterations of A.


To apply an upper limit to the number of iterations, follow the last brace with an integer defining the maximum number of iterations. For example: {A}5 means that the maximum number of iterations of A is five.

ALIAS
means that the data item's structure is identical to another, named data item. For example: for data item A, the syntax ALIAS B means that the structure of A is identical to the structure of data item B.

/
A data item whose structure is an enumeration type has its structure represented as: /A1/A2/A3/ where A1, A2 and A3 are the values of the enumeration.
You will start with data item Driver_Command on the control flow.  To enter the data item definition, 

· Right click on the data item Driver_Command and then select Edit Data Item, or 

· Double click on the data item Driver_Command while holding the control key down.

In the Data Item Driver_Command window, enter the following text in the upper sub-window:

This information defines the commands that can be entered by the driver.

Enter the following structure definition in the lower sub-window.
[Activate
|Deactivate
|Resume
|Start_Accelerate
|Stop_Accelerate
|Monitor_Command
|Calibrate_Command]

Select the File menu, the Close menu item and the Yes button, to save the data item definition in the data dictionary and close the Data Item Driver_Command window.

In the context diagram, verify that the asterisk next to the Driver_Command data item has been removed, indicating that the data item has been defined.

You will now intentionally cause a syntax error in the data item definition to show how errors are handled.  

Add the data item Displays definition:

· Right click on the data item Displays and then select Edit Data Item, or

· Double click on the data item displays while holding the control key down.

In the Data Item Displays window, enter the following text in the upper sub-window:

This is the data to be displayed to the driver.

Enter the following structure definition in the lower subwindow.


Fuel_Consumption+
Maintenance_Needed+
Average_Speed+

Select the File menu and click on Save or select the Save icon, [image: image18.png]


.  Since the data item BNF definition contains an error, an error message will be displayed in a new window.  In this case, the message indicates that a plus sign, ‘+’, is not followed by the name of a record component.  This error must be corrected and the data item saved again.  Note that the data item definition will NOT be saved if the BNF is syntactically invalid.

Delete the plus sign following Average_Speed to correct the error.

Select the File menu, the Close menu item and the Yes button to save the data item definition and close the Data Item Displays window.

Again, note that the asterisk following the data item Displays on the data flow in the context diagram has been removed.

Now, you will enter a data item definition and specify its attributes.  Enter the following definition for data item Fuel_Quantity in the upper subwindow, in the same manner as above:

This information is the entered value of fuel fill-up quantity.

Save this data item and then:

· Select the Show menu and click on Attributes.

· In the Data Item Attributes dialog box, enter the data as shown below, and select OK.
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The Units, Range, Accuracy, Resolution, and Rate attributes may be attached to any data item in the project.

Select the File menu, the Close menu item and the Yes button to save the data item definition and close the Data Item Fuel_Quantity window.

You will complete the context diagram by defining all the remaining data items associated with the data and control flows with the descriptions and structures shown below:

Throttle_Position

This information is the output signal which drives the throttle position.


Braking 


This information indicates when the driver is braking the automobile.

ALIAS Boolean

Calibrate_Parameters


This information is the calibration parameters.

Lower_Limit +
Upper_Limit +
Default_Count

Running


This information indicates when the engine is running.

ALIAS Boolean

Top_Gear

This information indicates when the vehicle is in top gear.

[Top_Gear_Off
|Top_Gear_On]

Shaft_Rotation:


This information is the input pulse stream corresponding to the shaft angular rotation.


Now return to the context diagram.  If the context diagram is not displayed, select the Window menu and click on Flow Diagram Cruise_Control.  In the context diagram, verify that no asterisks appear, since all related information has been entered into the project.

3.12 Browsing Data Items

Now, you will look at the browsing capability of AxiomSys.

Select the Edit Data Dictionary Item icon, [image: image20.png]


.

The following Data Item dialog box will be displayed:


If the Undefined Data Items option is selected, undefined data items will be displayed in the Data Item List.  Where did these names come from?

When you entered the definition for the data items, several of them had components.  These components are now known to the system and they have no defining entry in the data dictionary.  These data items can now be defined.  

Do the following to define the data item Boolean:

· Double click on Boolean in the Data Item List.

· Enter the following definition for data item Boolean:

This information is a standard Boolean value.


 /TRUE/FALSE/

If the Data Item dialog box is displayed again, you will find that Boolean is no longer shown in the Data Item List of Undefined Data Items.

Display the Data Item dialog box by selecting the Edit Data Dictionary Item icon, [image: image21.png]



In the Data Item dialog box, select the Defined Data Items option.  As shown in the following figure, the Data Item List now contains all data items that have definitions.
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If a data item name is proceeded by a plus sign, the data item has components. The data item can be expanded to show the components by clicking on the plus sign. The plus sign is now changed to a minus sign to show that the data item has been expanded to show its components. Clicking a minus sign will collapse the expansion of the that data item and change the minus sign to a plus sign.

Select the Close button in the Data Item dialog box to close the dialog box..

4 Child Flow Diagram Creation

Now, let's create the child flow diagram Control_And_Monitor_Auto process:

· Right click on the Control_And_Monitor_Auto process located in the context diagram Cruise_Control and select Edit Flow Diagram from the resulting pop-up, or

· Double click within the process Control_And_Monitor_Auto.

The blank Flow Diagram Control_And_Monitor_Auto window is now displayed.

4.1 Adding a Process

Add the following processes to the flow diagram (refer to the diagram on page 17 for a copy of the flow diagram):

1. Process Measure_Motion as a primitive process:

· Click on the Create Process icon, [image: image23.png]


, located on the tool bar.

· Position the cursor and click on the left mouse button.

· In the Create Process dialog box, enter “Measure_\Motion” in the Name field, “1” in the Number field. Check the Is Primitive option and click on the OK button.

2. Process Measure_Mile as a primitive process.

3. Process Control_Throttle as a non-primitive process.

4. Process Monitor_Status as a non-primitive process.

In the flow diagram, note that 

· Non-primitive processes are grayed to indicate that child flow diagrams are required for these processes and they are not defined in the project data base at this time.

· The primitive processes are not grayed and their names are shown in bold typeface.  It may be necessary to zoom in on the diagram in order to see the difference between bold and non-bold typefaces.  To zoom in, select the Zoom In icon, [image: image24.png]


 located on the tool bar.

· All process names are followed by an asterisk, indicating that the associated p‑specs are undefined at this time.

4.2 Adding a Flow

Next, you will start creating the data and control flows for this diagram (refer to the diagram on page 17 for a copy of the flow diagram).

Select the Create Data Flow icon, [image: image25.png]


.

Move the cursor to the left of process Measure_Motion.

Click the left mouse button to begin creating a horizontal data flow entering the process Measure_Motion from the left hand side of the diagram.

Double click in process Measure_Motion to complete the data flow and the Create Flow dialog box will be displayed:
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In the Create Flow dialog box, the List of Input Data Items contains the data items on data flows entering the parent process, and the List of Output Data Items contains the data items leaving the parent process.  In this dialog box, the List of Input Data Items contains the input data items to process Control_And_Monitor_Auto as defined in context diagram Cruise_Control, and the List of Out Data Items contains the output data items from process Control_And_Monitor_Auto.  These two lists act as a prompt to remind you which data items must balance with the parent flow diagram. The lists also serve as the entry method for the data items so that you do not have to type any names.

Add Shaft_Rotation to the data flow as follows:

· Double click on Shaft_Rotation in the List of Input Data Items.  Note that Shaft_Rotati1on is now shown in the List of Data Items on Flow.

· Click on the OK button.

You will now enter a control flow to demonstrate the ability to add components of data items on control flows to/from the flow diagram.

Click on the Create Control icon, [image: image27.png]


, move the cursor to the left of process Control_Throttle, and click the left mouse button to begin creating a horizontal control flow entering process Control_Throttle from the left hand side of the diagram.

Double click in process Control_Throttle to complete the control flow. The Create Flow dialog box will be displayed:
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In this dialog box, the List of Input Data Items contains the data items on control flows entering the parent process of the flow diagram.  The List of Output Data Items contains the data items on control flows leaving the parent process.

The control flow being created will have several names associated with it.  This is a special feature of AxiomSys.  Many CASE tools allow only a single data item to be associated with a data or control flow.  Thus, if several data items originate from the same object and terminate in the same object, several data or control flows must be drawn.  With AxiomSys, only one flow needs to be drawn; this results in diagrams that are less cluttered and easier to understand.

The control flow being entered will have the following data items associated with it: Braking, Resume, Running, Start_Accelerate, Stop_Accelerate and Top_Gear. These data items will be added as follows:

· Double click on Braking in the List of Input Data Items.

· Double click on Running in the List of Input Data Items.

· Double click on Top_Gear in the List of Input Data Items.

At this time, the List of Data Items on Flow should contain Braking, Running and Top_Gear.

The remaining names are components of data item Driver_Command. To add these names, perform the following:

· Click on the plus sign preceeding Driver_Command in the List of Input Data Items. The data item Driver_Command will be expanded to show its components.

· Double click on Start_Accelerate in the List of Input Data Items.

· Double click on Stop_Accelerate in the List of input Data Items.

· Double click on Resume in the List of Input Data Items.

At this point, Braking, Resume, Running, Start_Accelerate, Stop_Accelerate and Top_Gear should be displayed in the List of Data Items on Flow.

Select the OK button in the Create Flow dialog box to complete the creation of the control flow.

4.3 Adding a Data Store

Do the following to add data store Mile_Count to the flow diagram:

· Select the Create Data Store icon, [image: image29.png]


.

· Move the cursor to the location on flow diagram to place the data store and click on the left mouse button (see the flow diagram shown below for the data store location).

· In the Create Data Store dialog box, enter “Mile_Count” in the Data Store field, and click on the OK button.

A copy of the flow diagram is shown below.  In the flow diagram, note the asterisk following Mile_Count in the data store.  Again, the asterisk indicates that the data item is undefined.

Moving or re-sizing a data store is similar to moving or re-sizing a process.  For details, refer to Paragraph 3.2, Moving/Re-sizing a Process.

Add the additional data store, data flows and control flows to make the flow diagram appear as follows:
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When adding the flows entering or exiting the stores, the names to not need to be displayed on the flows since the name of the flow is the same as the name of the store. To suppress the display of the flow name on these flows, clear the check box Display Data Items on Flow in the Data Flow Attributes dialog box before selecting the OK button.

For the flow between the data store Distance_Count and the process Measure_Motion, the data goes in both directions. When entering this flow, select the Bidirectional check box in the Data Flow Attributes dialog box before selecting the OK button.

Select the File menu and then click on Save, or select the Save icon, [image: image31.png]


 to save the flow diagram.

We will now check the syntax of the diagram, to assure that no diagramming errors appear on the diagram. Select the Validate pull-down menu and then select the Diagram Syntax option. If your diagram appears as above you will receive a message saying that no errors were found. If you have any syntax errors they will be displayed in a new window. If this occurs, check to assure that your diagram is exactly like the diagram above.

4.4 Balancing Flow Diagrams to Processes

Now, you will check the balancing between the flow diagram and its parent.

Select the Validate menu and click on Against Parent Diagram. 

A new window with a list of errors should be displayed.

The errors indicate that data item Driver_Command or its components Activate, Calibrate_Command and Deactivate are not used in flow diagram Control_And_Monitor_Auto although they are inputs to process Control_And_Monitor_Auto in the parent flow diagram.

To verify this,

· Select the Goto button, [image: image32.png]


.

· In the resulting pop-up menu, select Parent Flow Diagram.

· In the parent flow diagram (context diagram Cruise_Control),  verify that data item Driver_Command is an input to the process Control_And_Monitor_Auto.

· Double click on the process Control_And_Monitor_Auto, and select Edit Flow Diagram to return to flow diagram Control_And_Monitor_Auto.

These errors can be corrected now or at a later time.  The next paragraph will show you how to fix these errors.

4.5 Adding a Bar

These three missing components are utilized, not by a data process, but by a control process.  The control process is represented on the flow diagram by a bar.  The bar is a bold solid line on the diagram.  This is the symbol suggested by Hatley and Pirbhai in Strategies for Real-Time System Specifications.

First, do the following to create a bar:

· From the tool bar, select the Create Bar icon, [image: image33.png]


.

· Move the cursor to the mid-point between process Control_Throttle and process Monitor_Status (see figure shown below for the bar location) and click on the left mouse button.

To exit the create bar mode, select the Cancel Create icon, [image: image34.png]


, located on the tool bar.

To reposition the bar, click on the bar and drag it to the new location.

To reorient or resize the bar:

· Click on the bar to select it.

· Click and drag on one of the end-points to reorient or resize the bar.

Now, create a control flow that ends in the bar with the following data items: Activate, Calibrate_Command, Deactivate and Running.

Also create a control flow the originates form the bar and terminates in the process Control_Throttle with the data item Init_Cruise. 

The flow diagram should look like the figure shown below: 
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Select the File menu and Save, or select the Save icon, [image: image36.png]


 to save the flow diagram.

Select the Validate pull-down menu and then select Diagram Syntax. The response should indicate that no errors are present.

Select the Validate menu and Against Parent Diagram to rerun the balancing of the flow diagram against its parent.

If everything is entered as shown on the above flow diagram, a message indicating that no error is found will be displayed.

4.6 Browsing P-specs

Select the Edit P-spec icon, [image: image37.png]


 to browse p-specs:

The following P-spec dialog box will be displayed:
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If you click on a p-spec in the P-spec List the name will be entered as the P-spec Name and you may then edit, rename or delete the P-spec by selecting the appropriate button. Double clicking on the P-spec name in the list will automatically put you in the edit mode for the P-spec.

You can select to see the list of undefined p-specs (the process exist, but no p-spec has been written), the defined p-specs (the p-spec has been written, whether a process exists or not) and unreferenced p-specs (the p-spec has been written, but no corresponding process exists on any diagram).

This browse capability is available for all object types in the project.  You will now investigate some of these browse features.

4.7 Browsing Flow Diagrams

Select the Edit flow diagram icon, [image: image39.png]


 to browse flow diagrams:

The Flow Diagram dialog box will be displayed.  This dialog box can display the list of flow diagram in several different ways.

· In Hierarchical Order.  When this option is selected, the FD List contains all flow diagrams and processes in the project, including those that are declared as being primitive.  The following is the dialog box with the In Hierarchical Order option selected:
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In this dialog box if a flow diagram is already expanded to its next level, the name will be preceded with a minus sign. If a flow diagram has processes but it has not been expanded in the list, the name will be preceded by a plus sign. Selecting the plus or minus sign will either expand or contract the selected level of the hierarchy. If a name in the list is preceded by neither a plus or minus sign, it indicates that that process is either a primitive process or a non-primitive process that has not yet been expanded into a child diagram.

· In Alphabetical Order.  When this option is selected, the FD List contains, in alphabetical order, all flow diagrams in the project in one of three different groupings. If Undefined Diagrams is selected, a list of all non-primitive processes in the system that do not have child diagrams will be displayed. If Defined Diagrams is selected, a list of all the flow diagrams in the system will be presented. If Unreferenced Diagrams is selected, a list of all diagrams in the system that to not link into the hierarchy from the context diagram will be presented. The following is the dialog box with the In Alphabetical Order - Undefined Diagrams option selected:
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This shows that the processes Control_Throttle and Monitor_Status on the flow diagram Control_And_Monitor_Auto are non-primitive processes and their child diagrams have not yet been created.

Select Defined Diagrams and then double click on Control_And_Monitor_Auto to edit the flow diagram.

4.8 Adding a C-spec

Now, you will create the c-spec associated with the flow diagram Control_And_Monitor_Auto.

In flow diagram Control_And_Monitor_Auto, right click on the bar.  When the pop-up menu is displayed, select  Edit C-spec or double click on the bar. The Create C-spec dialog box will be displayed as follows:
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Since the c-spec for this diagram has not been created, this dialog box allows you to specify the type of c-spec to be created. The c-spec can be a guide, for complicated c-specs that will require multiple state transition diagrams and/or control tables to specify them, it can be a state transition diagram or a control table. A control table is used to define a decision table, a process activation table or a combination of a decision table and process activation table.

For this c-spec select the State Transition Diagram option and then select OK.

The C-spec Control_And_Monitor_Auto window will be displayed.

4.8.1 Adding a State

The creation of a state transition diagram c-spec is very similar to the creation of a flow diagram; but only two objects exist in the state transition diagram: the state and the transition.

To create a state:

· Select the Create State icon, [image: image43.png]


, located on the tool bar.

· Move the cursor to the desired position and click on the left mouse button.

· When the Create State dialog box is displayed, enter the state name in the State field and select the OK button.

To exit the create state mode, select the Cancel Create icon, [image: image44.png]


, located on the tool bar.

Moving or re-sizing a state is similar to moving or re-sizing a process.  For details, refer to Paragraph 3.2, Moving/Re-sizing a Process.

In the Control_And_Monitor_Auto state transition diagram c-spec, you will create three states: the Calibrating, Inactive and Cruising states.  Refer to the diagram on page 26 for the state locations.

4.8.2 Adding a Transition

To add a transition:

· Select the Create Transition icon, [image: image45.png]


, located on the tool bar.

· Move the cursor to the desired start point and click on the left mouse button.

· Move the cursor to any intermediate points and click on the left mouse button.

· Move the cursor to the end point and double click the left mouse button.

· The Transition Attributes dialog box, shown below, will be displayed.  The dialog box has three tab sections: Event for entering the event that causes the transition, Control Flow Action for entering the control flow actions (data items) that are raised as a result of the transition and Process for defining processes that will be enabled as a result of the transition.
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To add an event to the List of Events, select the Event tab and

· Move the cursor to one of the events in the Input Control Flows and double click the left mouse button, or

· Move the cursor to one of the events in the Input Control Flows, click the left mouse button and then click on the Add/Remove Event button, or

· Enter the event name in the Event Name field and click on the Add/Remove Event button.

If the event is a complex event, the events can be combined using Boolean logic. When entering events after the first one, select the appropriate options of And, Or and Not. Also each event can be compared to an expression. If the event is to be compared to an expression, enter the expression before selecting the Add/Remove button.

To remove an event from the List of Events, 

· Move the cursor to one of the events in the Event List and double click the left mouse button, or

· Move the cursor to one of the events in the Event List, click the left mouse button and click on the Add/Remove Event button.

To add a control flow action to the Control Flow Action List, select the Control Flow Action tab and:

· Move the cursor to one of the actions in the Output Control Flows and double click the left mouse button, or

· Move the cursor to one of the actions in the Output Control Flows, click the left mouse button and then click on the Add/Remove Action button, or

· Enter the action name in the Control Flow Name field and click on the Add/Remove Action button.

If the control flow is to be set to a value when the transition occurs, enter this information in the expression field before adding the event to the list.

To add a process activation to the Process Lists, select the Process tab and:

· Move the cursor to one of the processes in the Processes on Flow Diagram and double click the left mouse button, or

· Move the cursor to one of the processes in the Processes on Flow Diagram, click the left mouse button and then click on the Add/Remove Process button, or

· Enter the process name in the Process Name field and click on the Add/Remove Process button.

· Select the OK button to complete the transition creation when all events and actions have been defined.

To exit the Create Transition mode, select the Go to select mode icon, [image: image47.png]


, located on the tool bar.

Moving a transition is similar to moving a data flow.  For details, refer to Paragraph 3.5, Moving  a Data Flow.

In the Control_And_Monitor_Auto state transition diagram c-spec, you will create the following transitions:

1. Event Activate activates process Control_Throttle and raises the Init_Cruise control flow.

2. Event Start_Measure_Mile activates process Measure_Mile.

3. Event Stop_Measure_Mile.

4. Event Deactivate.

5. Event Running which initializes the system in the inactivate state.

The Control_And_Monitor_Auto state transition diagram c-spec should appear as follows:
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Again, note the asterisk following the data items.  The asterisk indicates that the data item is undefined.

Select the File menu and Save, or  select the Save icon, [image: image49.png]


 to save the c-spec.

4.8.3 Validating the C-spec

Select the Validate pull-down menu and then select Diagram Syntax. If any syntax errors are present in the diagram, a new window will be opened with the list of errors. In this case if your diagram appears as above, you should receive an indication that no errors were found.

Select the Validate pull-down menu and Against Parent Diagram 

If any errors are detected in the balancing, they will be presented in a new window. If your state transition diagram appears as above, you should receive the following errors:

· Data item Calibrate_Command which is an input to the bar in the associated flow diagram is not referenced in the c-spec (if you refer to the diagram on page 19, you can verify that Calibrate_Command is an input to the bar).

· Events Start_Measure_Mile and Stop_Measure_Mile which are used in the c-spec are not present in the flow diagram. 

The above errors arise because data item Calibrate_Command has not been defined.  To fix the errors,

· Select the Edit Data Dictionary Item icon, [image: image50.png]


.

· In the Data Item dialog box, select the Undefined Data Items option.

· Double click on Calibrate_Command in the Data Item List.

· In the Data Item Calibrate_Command window, enter the following:

This information identifies a calibration command from the driver.

[Start_Measure_Mile
|Stop_Measure_Mile]

· Select the File menu and Save, or select the Save icon, [image: image51.png]


 to save the data item definition.

· Select the File menu and Close to close the data item window.

In the C-spec Control_And_Monitor_Auto window, select the Validate pull-down menu and then Against Parent Diagram to rerun the balancing.

If everything is entered correctly, the “no error found” message should be displayed.

5 Validating the AxiomSys Project

A validation of the complete project will now be performed.

Select the Project pull-down menu, and the Validate Model option.

The Validate Project dialog box will be displayed.  Since you will validate the entire project,  select the Check All Options button and then select the Validate button.

The validation results will be displayed in a new window.  Because you have not completed the model by adding all data items, p-specs and child flow diagrams, many errors are displayed.  These errors will not be corrected in this tutorial.  By examining the error messages and inspecting the Cruise project data base included with the demonstration and commercial versions of AxiomSys, you can clear all the errors.  This is left as an exercise.

6 Creating Reports

Now, you will investigate the report features of AxiomSys.  You will learn:

· How to define a report template that defines the report sections to be incorporated into a report.

· How to output the report either directly to a printer or to a Rich Text Format (RTF) file compatible with Microsoft-Word and other word processors.

6.1 Creating a Report Template

Now, you will create a template to generate a report.  Templates are delivered with the system that support the DOD-2167A SRS and IRS.  You will create a new template to learn how templates are created.

Select the Project menu, and the Print Report/Edit Report Template menu item.

In the Generate Report dialog box, enter “Tutorial” in the File Name field, and select the Edit button. Respond Yes to the create dialog box.

The following dialog box will be displayed:
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Through this dialog box, you will define the contents of the report.  Enter “Tutorial Report”  in the Report Template Description field. The List  of Possible Sections defines the report sections that can be included in a report generated by AxiomSys.

The first section of the report to be generated will be section 1 and will be called “Introduction”. To create this section, double click on the Canned Text option in the List of Possible Sections. Fill out the Add Canned Text dialog box to appear as follows:
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Select the OK button to add this section to your report template.

Add section 2, Referenced Documents, as a canned text section also. The Add Canned Text dialog box will appear as follows prior to selecting the OK button.
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The Edit Report Templates dialog box now appears as follows:
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In the List of Sections to Generate, you see the two sections that have been defined for this report. There are listed with their section number, title, and type of section, in parentheses.

We will now add section 3 to this report. This section will consist of the flow diagrams of the system, in hierarchical order, with the p-spec for the diagram included.

Double click on the Process Subtree option in the List of Possible Sections. Fill out the Add Process Subtree dialog box to appear as follows:
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You will notice that the Context Diagram box is checked. This is because we wish to start our section with the root diagram of the system, the context diagram. We will now add the flow diagram and p-spec to our report. Double click on the Flow Diagram option in the List of Possible Subsections.

Fill out the Add Flow Diagram dialog box to appear as follows:
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You will notice that both the Data Information in Diagram and Control Information in Diagram boxes are checked. This will cause the diagram to be printed containing both the data and control information. You have the option of printing the diagram with either data or control or both sets of information.

You will also notice that the number header section box is checked. Thus the diagram will have its own section number. The section number will be one level below the parent section, which is section number 3.

Finally, notice the use of %1 and %3 in the text boxes. As shown, the placeholder %1 will be replaced with the name of the flow diagram and %3 will be replaced with the figure number. The use of %3 allows for the generation of a table of figures in the final report.

Select OK to add this section to the report.

Now double click on the P-spec option in the List of Possible Sections. Fill out Add P-spec dialog box to appear as follows:
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The P-spec will not have its own section number, so the Number Header box is cleared. Again, notice the use of the placeholder %1.

Select the OK button to add this section to the report.

The Add Process Subtree dialog box should now appear as follows:
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We have now completed the definition of Section 3 of our report. Select the OK button to complete the addition of this section to our report.

The Edit Report Template dialog box should now appear as follows:
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Select the OK button to complete the generation of the tutorial report template.

6.2 Printing the Report

To print a report using the report template created in the previous paragraph, do the following:

· Select the Project menu and the Print Report/Edit Report Template menu item.

· In the Generate Report dialog box, select Tutorial from the list of templates.

· To print the report directly to your printer, select the Print button.  To generate a report that can be imported to Microsoft Word, Word Perfect or other word processors that support Rich Text Format files, select the Rich Text Format button. 

At this point, you have complete Part I of this tutorial.  Now, you will exit AxiomSys.  To exit AxiomSys, select the File menu and the Exit menu item.

Part II. Building an Architecture Model

7 Architecture Modeling Overview

Architectural Modeling is a method of defining the components that will be used to implement the essential requirements defined in the Structured Analysis model. 

In Architecture Modeling, your system can be thought of as being implemented by a module that transforms the inputs of your system into the outputs from your system. This module is not the same as the context process of the Structured Analysis model, since defining the architecture of the system will result in making design decisions that will result in having to enhance the essential model processing defined in the Structured Analysis model. This module is then decomposed or refined into a set of simpler child modules.  The child modules are then further refined as necessary until modules that require no further refinement are reached. The modules that require no further refinement are called primitive modules. 

In Architecture Modeling, a module is a component of your systems that implements a set of Structured Analysis processes.

In Architecture Modeling, a channel serves as a link carrying Structured Analysis data items between modules.

Architecture flow diagrams, architecture interconnect diagrams and module specifications are used to describe a module.

An architectural flow diagram is a graphical means to describe a module.  It shows the flow of information (data items) between modules.  The top level architecture flow diagram is the architecture context diagram.

An architecture interconnect diagram is a graphical means to describe a module.  It shows the channels which connect the modules and via which the data flows between the modules.

The integrity of the system is validated by checking the consistency between the Structured Analysis and Architecture Models.

Again, AxiomSys can generate automated reports from the information contained in the models developed.

8 Creating the Architecture Context Diagram

Let’s open the project data base created in Part I of this tutorial:

· Double click on the AxiomSys icon to run AxiomSys.

· In AxiomSys, select the Project menu and the Open menu item.

· In the Open Project dialog box, enter ”new” in the Project Name field and select the OK button.

To begin creating an architecture context diagram, select the Edit Architecture Context Diagram icon, [image: image61.png]


.

In the Architecture Context Diagram dialog box, enter “Cruise_Control_Architecture” in the Name field, and select the Edit Arch. Flow Diagram button.

The following empty architecture context diagram is displayed:
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The lines and notes on this diagram form what is known as the architecture template. The Maintenance section of this diagram will not be used for this model.  To remove this section, right click on the line above the Maintenance section and select Delete from the pop-up menu. Also, right click on the word Maintenance and select Delete from the pop-up menu. 

To move a section label, click and drag the label to its new position.

8.1 Adding a Module

Next you will enter a module on the diagram.

Select the Create Module icon, [image: image63.png]


, located on the tool bar.

Position the cursor in the middle of the diagram and select the left mouse button.

When the Module Attributes dialog box is displayed, 

· Enter “Automobile_\Management_\System” in the Module Name field.  Note that when this name is displayed on the diagram, a new line will be inserted where backslash, “\”, was entered.

· Enter “0” in the Module ID field.

· Enter “1” in the Number of Modules field.

· Clear the Is Primitive option to indicate that the module will be decomposed further to submodules.

· Click on the OK button to complete the module creation.

The architecture diagram now contains the module.  Note the following:

· The module is grayed.  Graying of the module is used to indicate that the module is not a primitive module and that no child architecture diagram exists for the module.

· An asterisk is displayed next to the module name.  This indicates that the module specification has not been defined.

· If a module is a primitive module, the module name will be displayed in bold.

This information is part of the Intelligent Diagram information presented on AxiomSys diagrams.  You can tell at a glance the work remaining to be done by looking at the displayed diagram.

To exit the Create Module mode, click on the Go to Select mode icon, [image: image64.png]


, located on the tool bar.

Moving and re-sizing a module is similar to moving and re-sizing a process.  For details, refer to Paragraph 3.2, Moving/Re-sizing a Process.

8.2 Adding a Terminator

Next you will add the terminators to the architecture diagram.  Refer to the diagram on page 38 for the location and name of the terminators.

Adding a terminator to an architecture diagram is similar to adding a terminator to a flow diagram.  For details, refer to Paragraph 3.3, Adding a Terminator.

8.3 Adding an Architecture Data Flow

Next, generate a data flow connecting terminator Driver to module Automobile_Management_System in the following manner:

· Click on the Create Data Flow icon, [image: image65.png]


, located on the tool bar.

· Position the cursor in the terminator Driver and click the left mouse button.

· Move the cursor inside module Automobile_Management_System and double click the left mouse button.  You can insert intermediate points on the data flow by single clicking the left mouse button before the final double click within the module.

· In the Architecture Flow Attributes dialog box, enter “Driver_Entries” in the Data Item field.

· To add this name to the List of Data Items on Flow, select the Add button.  Again, note the asterisk following the data item name in the List of Data Items on Flow.  The asterisk indicates that the data item is undefined.

· Select the OK button to complete the creation of the data flow.

In the same manner, add the architecture data flows to make the architecture diagram appear as shown below.

To exit the create data flow mode, select the Go to select mode icon located on the tool bar.

Moving architecture data flows is similar to moving data flows on a flow diagram.  For details, refer to Paragraph 3.5, Moving  a Data Flow.

Adding control flows to an architecture diagram is similar to adding data flows to an architecture diagram, except that the icon to be selected from the tool bar is the Create Control Flow button, [image: image66.png]


.
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Up to now, none of the work has been saved to the project data base.  You have only been drawing the diagram on the screen.  Select the File menu and the Save menu item, or select the Save icon, [image: image68.png]


 to save this diagram to the project data base.

We will now validate the syntax of the architecture context diagram. Select the Validate pull-down menu and then select Diagram Syntax. The errors (if any) present will be displayed in a new window. In this case we find that no channels are present. This error will now be corrected.

8.4 Adding Channels

The architecture context diagram is currently displayed as an architecture flow diagram. This same diagram can also be displayed as an architecture interconnect diagram. The architecture interconnect diagram has the same modules present as on the flow diagram, but the flows are not shown, instead the channels that carry the information between the modules are shown. To convert the diagram to an interconnect diagram, right click in empty space on the diagram and then select Show Architecture Interconnect Diagram from the pop-up menu.

You will now add the channel between the Driver Terminator and the Automobile_Management_System module.

· Select the Channel icon, [image: image69.png]


, located on the tool bar.

· Click in the Driver terminator and then double click inside the Automobile_Management_System module.

· In the Channel Attributes dialog box, enter “Ext_Driver_Bus” in the Channel field, check the Display Channel Name option, select the Bus option, and select the OK button.  The figure shown below is the Channel Attributes dialog box before the OK button is pressed.

[image: image70.png]Channel Attributes

Chanre = ]

Lol Chomels =

=

¥ Display Channel Name:

Chanrel Type——————————————————
@ Bus O Mechanicallik " OptcalLink





Select the OK button to add the channel to the diagram.

Continue to add channels to the diagram until it appears as follows:


Save this diagram to the data base. 

Now we will revalidate the syntax for the diagram. Select the Validate pull-down menu and then select the Diagram Syntax option. If your diagram matches the above diagram, you will receive the no errors found message.

8.5 Adding a Module Specification

A module specification is a textual description of the module with which it is associated.

You will now add the module specification for the Automobile_Management_System module..  Writing these module specifications will allow for the generation of a final report that will be much easier to read and understand than if module specifications were written only for primitive modules.

Now, do the following to enter the module specification associated with the module Automobile_Management_System:

· Right Click on module Automobile_Management_System and select Edit Module Specification from the pop-up menu or

· Double click on the Automobile_Management_System module while holding the control key down.

· Enter the following text in the Module Automobile_Management_System window:

This is the architecture model representing the entire cruise control system.

· Select the File menu and the Close menu item.

· When prompted to save data, select the Yes button.

8.6 Adding a Terminator Specification

Adding a terminator specification in the Architecture Model is performed in the same manner as in the Structured Analysis Model.  For details, refer to Paragraph 3.10, Adding Terminator Text.

8.7 Adding a Data Item Definition

Adding a data item definition to the Architecture Model is performed in the same manner as in the Structured Analysis Model.  For details, refer to Paragraph 3.11, Entering Data Item Definition.

8.8 Adding a Channel Specification

A channel specification is a textual description of the channel with which it is associated.

You will now enter the following channel specification for channel Ext_Driver_Bus:

This is the channel connecting the driver I/O devices to the cruise control system.

To enter the channel specification:

· Right click on the channel and select Edit Channel Description from the pop-up menu or

· Double click on the channel while holding the control key down.

When the channel window is displayed, enter the channel specification. Then select the File menu and the close option. Respond Yes when prompted to save the data.

In the architecture interconnect diagram Cruise_Control_Architecture, note that the asterisk following Ext_Driver_Bus is no longer displayed.  An asterisk next to a channel name indicates that the channel specification is undefined.

Now add the following channel specifications:

Ext_Shaft_Bus

This is the channel connecting the drive shaft to the cruise control system.

Ext_Engine_Bus

This is the channel connecting the engine to the cruise control system.

Ext_Brake_Bus

This is the channel connecting the brake to the cruise control system.

Ext_Gear_Bus

This is the channel connecting the transmission to the cruise control system.

Ext_Throttle_Bus

This is the channel connecting the throttle to the cruise control system.

Ext_DataBase_Bus

This is the channel connecting the data base to the cruise control system.

8.9 Assigning a Data Item to a Channel

For each channel, you define the data items that flow over the channel.  You can build the list of data items starting from the channel or from the data item.  Both methods will be shown.

Before the data items can be assigned to the channel they must be defined. Therefore, make the following data dictionary entries:

Driver_Entries

The raw driver inputs to the system.

Driver_Displays

The display data from the system to the driver.

Shaft_Position

The raw shaft data to the system.

Engine_Status

The raw engine data to the system.

Brake_Position

The raw brake position information to the system.

Gear_Status

The raw transmission data to the system.

Throttle_Drive

The system throttle data to the throttle.

To assign a data item to a channel from the channel:
· Right click on channel Ext_Driver_Bus.

· Select Edit Channel Specification from the pop-up menu.

· In the Channel Ext_Driver_Bus window, select the Show menu and the Assigned Data Items menu item.

· In the Assign Channel to Data Item dialog box, select the Browse button.

· In the Browse Data Item, select the Defined Data Items option.

· Scroll the Data Item List until Driver_Entries is visible and double click on Driver_Entries.

· In the Assign Channel to Data Item dialog box, select the Assign/Deassign button.

· In the same manner add the data item Driver_Displays to the channel.

· Select the Exit button to terminate the assignment of data items to the channel.

· In the Channel Ext_Driver_Bus window, select the File menu and the Close menu item.

To assign a data item to a channel from the data item:
· Select the Edit Data Dictionary item icon, [image: image71.png]


.

· In the Data Item dialog box, select the Defined Data Items option.

· Scroll the Data Item List until Shaft_Position is visible and double click on Shaft_Position.

· In the Data Item Shaft_Position window, select the Show menu and the Assigned Channels menu item.

· In the Assign Channel to Data Item dialog box, select the Browse button.

· In the Browse Channel dialog box, select the Defined Channels option.

· In the Channel List, double click on Ext_Shaft_Bus.

· In  the Assign Data Item to Channel dialog box, select the Assign/Deassign button.

· Select the Exit button to complete the entry.

· In the Data Item Shaft_Position window, select File and then Close.

In a similar manner make the following data item to channel assignments:

Channel Ext_Engine_Bus - Data item Engine_Status

Channel Ext_Brake_Bus - Data item Brake_Position

Channel Ext_Gear_Bus - Data item Gear_Status

Channel Ext_Throttle_Bus - Data Item Throttle_Drive

Channel Ext_DataBase_Bus - Data Item Calibrate_Parameters
9 Creating Architecture Flow Diagrams

Now, you will create the architecture flow diagram of module Automobile_Management_System.

In the architecture context diagram, right click on the Automobile_Management_System module and select Edit Architecture Diagram from the pop-up or double click in the .Automobile_Manangement_System module. The Architecture Flow Diagram Automobile_Management_System window will be displayed.

Since the Maintenance section is not needed in this diagram, you will remove it as on the architecture context diagram.  

Add modules to make your architecture flow diagram appear as shown below:
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Note that these modules are all primitive, they are not grayed and their names are shown in bold typeface.  It may be necessary to zoom in to see the difference between bold and non-bold typefaces.  To zoom in, select the Zoom In icon, [image: image73.png]


.

Also, note that all module names are followed by an asterisk, indicating that the associated module specifications are undefined. 

In creating this diagram, we have made the decision that the essential processing of the cruise control system will be performed in the Automobile_Management_Computer module and that there will be modules to interface each piece of hardware in the system to the Autombile_Management_Computer module.

9.1 Adding Architecture Data and Control Flows

Next, you will start creating the architecture data and control flows for this diagram.

Create a horizontal architecture data flow entering Driver_Interface_Module from the left hand side of the diagram:

· Select the Create Architecture Data Flow icon, [image: image74.png]


, located on the tool bar.

· Click at a point on the left of Driver_Interface_Module to begin the data flow drawing.

· Double click in Driver_Interface_Module to complete the data flow drawing.

The following dialog box will be displayed:

[image: image75.png]Datatem

[x]
(==

List of Data ltems on Flow: Browse

Cancel

I¥' Display Dataltems an Flow

I~ Bidiectionsl
Listof Input Data tems: Listof Quiput Data lems:
Diiver_Enties Diiver_Displays
Shalt_Pasiion Thictle_Drive

Engine_Status
Brake_Posiion
Goar_Status





In the dialog box, the List of Input Data Items contains the data items on data flows entering the module on the parent architecture diagram, and the List of Output Data Items contains the data items leaving the module on the parent architecture diagram. If you refer to the diagram on page 38, you will see that the inputs to module Automobile_Management_System are shown in the List of Input Data Items, and the outputs from the module are shown in the List of Output Data Item.  These two lists act as a reminder of the data items that must balance with the parent architecture flow diagram. The lists also serves as a way for you to enter the data without having to type any names.

To complete the architecture data flow creation,

· Double click on Driver_Entries in the List of Input Data Items.  Note that Driver_Entries is now in the List of Data Items on Flow.

· Select the OK button to complete the architecture data flow creation.

Next, do the following to create an architecture control flow leaving Driver_Interface_Module and entering Automobile_Management_Computer:

· Select the Create Architecture Control Flow icon, [image: image76.png]


, located in the tool bar.

· Click on Driver_Interface_Module to begin drawing the control flow.

· Double click on Automobile_Management_Computer to complete drawing the control flow.

· In the Architecture Flow Attributes dialog box, enter “Driver_Command” in the Data Item field, select the Add button and the OK button.

Add additional architecture data and control flows to make the diagram appear as follows:
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Select the File menu and the Save menu item, or select the Save icon, [image: image78.png]


 to save this diagram. Select the Validate pull-down menu and then select the Diagram Syntax option to validate the diagram syntax. The error messages will be displayed in a new window. The errors indicate that no channels are present on the diagram. You will correct these errors in the next paragraph.

10 Creating Architecture Interconnect Diagrams

Select the Goto icon, [image: image79.png]


, located on the tool bar, and select Show Architecture Interconnect Diagram from the pop-up menu or right click in empty space on the diagram and select Show Architecture Interconnect Diagram from the pop-up.

The architecture interconnect diagram is displayed.  Notice that 

· The diagram is similar to the architecture flow diagram.  The modules are in the same location in the architecture flow and the architecture interconnect diagrams.

· The architecture data and control flows are not shown in the architecture interconnect diagram.

10.1 Adding a Channel

A channel represents the physical medium that connects modules and by which data items flow. Notice that in the case where channels connect together, that the name is suppressed for display on one of the channels. This is to improve the readability of the diagram when the interconnected channels have the same name.

Before adding the channels, notice that on the diagram, the modules Shaft_Interface_Module and Throttle_Interface_Module appear differently than on the architecture flow diagram.

Sometimes duplicate modules exist in a system for safety or other reasons.  The existence of duplicate modules can be shown in AxiomSys.

To make the Shaft_Interface_Module consist of two identical modules, 

· Right click on Shaft_Interface_Module.

· Select Edit Attributes from the pop-up menu.

· In the Module Attributes dialog box, enter “2” in the Number of Modules field and select the OK button.

Note that the symbol used to represent module Shaft_Interface_Module is changed to represent duplicate modules.

In the same manner, change the number of modules for Throttle_Interface_Module to two.

Now, add channels to the diagram in the same manner as for the Architecture Context Diagram, to make it appear as follows:
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In the figure, note the asterisk following the channel name.  The asterisk indicates that the channel specification is undefined.  In other words, the channel specification has not been entered. The entry of the channel specifications and the assigning of data items to the channel is left as an exercise.  The process is the same as performed for the architecture context diagram.

11 Validating the Model

Select the Project menu, and the Validate Model menu item. In the  displayed dialog box, make sure that Check All Options is selected and then select the Validate button.

The validation messages will be displayed in a new window.  Since you have not yet completed the model by linking all data items and p-specs, many errors are displayed.  By examining the validation messages and inspecting the Cruise model included with both the demonstration and commercial versions of AxiomSys , you can clear all the errors. This is left as an exercise.

Additional errors are the result of the fact that the Structured Analysis Model and the Architecture Model are not yet linked together. The linking of the two models will be performed in the next part of the turtorial.

PART III

Each module in the Architecture Model must perform some of the functionality f the system defined in the essential requirements of the Structured Analysis Model, Additionally, because of the decision to include the interface modules in the architecture, it will be necessary to define some additional processing to handle the actual inputs to and outputs from the system. We will investigate these operations in this part of the tutorial.

The essential model diagrams will show the processing that is assigned to its associated module.

The enhanced flow diagram will add the new processing to the essential processing that is required by the design decisions that were made in generating the Architecture Model.

12 Generating the Essential Model Diagram for the Context Module

The architecture context diagram contains a single module. This module represents the implementation of the entire system being developed. The context flow diagram contains a single process. This process represents the complete essential processing to be performed by the system.

Associated with the module on the context diagram is an essential model diagram. An essential model diagram is a flow diagram with represents the essential requirements of the system that are allocated to the module. In this case the allocation to the Automobile_Management_System module will consist of the process Control_And_Monitor_Auto from the structured analysis context flow diagram and all of its inputs and outputs.

We will now build this diagram. Open the architecture context diagram Cruise_Control_Architecture. Right click on the module Automobile_Management_System and then select Edit Essential Model Diagram from the pop-up menu. The blank essential model diagram Automobile_Management_System is displayed. This diagram contains the architecture template which can be modified as necessary.

Now open the structured analysis context diagram Cruise_Control. Select the process on this diagram and all the data and control flows. Multiple object selection is performed by clicking on each object to selected while holding the shift key down. When all of the flows and process are selected, select the Edit pull-down menu and then select Copy.

Redisplay the essential model diagram Automobile_Management_System by selecting the Window pull-down menu and then selecting the desired diagram.

While the essential model diagram is displayed, select the Edit pull-down menu and select the Paste option. The copied process and flows will be inserted into the diagram.

The newly created essential model diagram can be cleaned up for presentation purposes. The updated essential model diagram Automobile_Management_System is shown below.



13 Generating the Enhanced Flow Diagram for the Context Module

Now that we have allocated the essential processing to the Automobile_Management_System essential model diagram, we need to augment this processing due to new requirements necessitated by the design decisions made in creating the architecture for the system. This augmented processing for the Automobile_Management_System module is recorded in the enhanced flow  diagram Automobile_Management_System.

To build the enhanced flow diagram for the Automobile_Management_System we will start by copying the essential model diagram to the enhanced flow diagram. This is because the enhanced flow diagram adds processing to the essential processing represented in the essential model diagram.

To do this select the File pull-down menu while the essential model diagram for the Automobile_Management_System is displayed, and then select the Save As option.

The Save As Dialog is presented. Select the enhanced flow diagram option and then select OK.

The essential model diagram will be saved as the enhanced flow diagram and the new enhanced flow diagram will become the active window, shown below.



One of the design decisions is that a module will exist to convert the raw information from the driver into the format needed by the essential cruise control processing. This module was called  the driver interface module. The reason this was left to the architecture is that there are several ways in which the driver could input the information. He could use a set of buttons and/or switches. In future automobiles, this could be done with a touch panel, or possible even voice input in the future. By isolating this to a separate module, these possible future technology changes are isolated from the essential processing and these changes would only affect the architecture model and not the Structured Analysis model. Thus a new process is required to convert the raw driver input to the format used in the essential processing. This same reasoning is also true for the inputs from the brake, the transmission, the engine, shaft and the outputs to the throttle. Then enhanced diagram for the Automobile_Management_System module is shown below with the new interface processes present.



The above enhanced flow diagram for the Automobile_Management_System module represents the complete processing to be performed by this module. Since it represents all the processing performed by the module the inputs and outputs to this diagram must balance to the inputs and outputs form the module as shown on the architecture flow diagram. This can be validated as follows:

· Select the Validate pull-down menu and select Against Associated Module

If you have entered the diagram as above, you should receive the no errors found message.

14 Generating the Essential Model diagrams for the Child Modules

The enhanced flow diagram Automobile_Management_System shows all the processing to be performed by that module. Since the Automobile_Management_System module is refined in a set of child modules on the architecture diagram Automobile_Management_System, all of the processing in the enhanced flow diagram must be allocated to at least one of these child modules.

We will look at the allocation of processing to the Driver_Interface_Module. The allocation is performed by creating the essential model diagram for the Driver_Interface_Module. Open the architecture diagram Automobile_Management_System and right click on the module Driver_Interface_Module and select the option Edit Essential Model Diagram. The blank essential model diagram Driver_Interface_Module will be displayed.

Now open the enhanced flow diagram Automobile_Management_System. What will be allocated to the Driver_Intreface_Module from this diagram is the process Interface_With_Driver and its inputs and outputs. Select this process and all of its inputs and outputs by clicking on them while holding the shift key down. Now select the Edit pull-down menu and select copy. Select the Window pull-down menu and select the Driver_Inerface_Module essential model diagram. When the diagram is displayed, select the Edit pull-down Menu and then select paste.

You can then reposition the pasted objects by selecting all the objects (clicking with the shift key held down) and then dragging to the center of the diagram. Your Driver_Interface_Module essential model diagram should look as follows:



The remaining modules should all have their essential model diagrams built in the same way. These diagrams would look as follows:













15 Generating the Enhanced Flow Diagrams for the Child Modules

Each of the modules on the Automobile_Management_System architecture diagram now has an associated essential model diagram. Each of these modules also needs a enhanced flow diagram. In the case of the simple model we are building here, there are actually no further enhancements to be performed, so the essential model diagrams and enhanced flow diagrams for each module are identical. Therefore creating the enhanced flow diagrams is very simple. Display each of the essential model diagrams and while it is displayed, select the File pull-down menu and then select Save As. In the displayed dialog box select the enhanced flow diagram button and then select OK. The essential model diagram will be saved as the enhanced diagram and the enhanced diagram will be made the active window.

In more complex models, each of the modules just built would require enhancement and then, if they were themselves composed of child modules, the process of allocating to the child module essential model diagrams and enhancing them would be repeated.

The entire module may now be checked for errors. Select the Project pull-down and select Validate Model. Be sure that the Check All Options is selected and then select the Validate Button. If you have made all entries correctly and performed the corrections left as exercises, you will have no errors in the model.

Summary

An introductory tour of AxiomSys has been presented.  In this tutorial, only some of the many features of AxiomSys have been investigated.  Experiment with the system, learn more of the capabilities of the best Real-Time Structured Analysis, Requirements Tracing and Report Generation CASE tool available on any platform.

All features and functions and complete definitions of all operations are found in the AxiomSys User’s Manual, supplied with each copy of AxiomSys.

For more information contact:

Structured Technology Group, Inc.
28157 Shelter Cove Drive
Saugus, CA 91350
Tel:
(661)296-3607, (800)959-2451
Fax:
(661)296-5302
E-mail: sales@stgcase.com
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